[virt-tools-list] ostype in virtinst and libvirt
Cleber Rosa
crosa at redhat.com
Tue Feb 16 14:08:44 UTC 2010
Folks,
I've been playing around with python-virtinst, with the primary goal of adding an initial round of LXC support to it.
While reading the code, I've found that "os_type" is quite misleading. This is already recognized and one example is this comment in virtinst/Guest.py:
# GAH! - installer.os_type = "hvm" or "xen" (aka xen paravirt)
# guest.os_type = "Solaris", "Windows", "Linux"
# FIXME: We should really rename this property to something else,
# change it throughout the codebase for readability sake, but
# maintain back compat.
libvirt also refers to "ostype" all over the place, one example is in conf/capabilities.c:
* virCapabilitiesAddGuest:
* @caps: capabilities to extend
* @ostype: guest operating system type ('hvm' or 'xen')
I feel that, even prior to adding LXC support to python-virtinst, I would benefit from learning more about the code while fixing this. I would like to have feedback on a couple of questions:
* Should libvirt be targeted also? Would this have any impact on ABI/API stability?
* Has a consensus been formed about alternative names for "ostype", "installer.os_type", "guest.os_type" and the like?
CR.
---
Cleber Rodrigues <crosa at redhat.com>
Solutions Architect - Red Hat, Inc.
Mobile: +55 61 9185.3454
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/virt-tools-list/attachments/20100216/937d0988/attachment.htm>
More information about the virt-tools-list
mailing list